Adding a Portable USB Monitor to Ubuntu: How to Set Up the DisplayLink Driver

Dual monitors are essential for productivity. They eliminate the interruption of having to flip back and forth between related activities. But what about when you're not at your desk? That's where portable USB monitors come in. (You also needn't spend a lot of money on one- the AOC E1659FWU, which at $89 on Amazon, is an absolute steal.) On Linux, installing the DisplayLink driver that AOC (and many other USB monitors) use isn't the simplest thing to do in the world. The chief reason being that the DisplayLink driver often doesn't present the correct list of available resolutions to Ubuntu. This often manifests itself as a USB monitor that turns on, but displays a bunch of vertical/squiggly lines. In this tutorial I will show you to how install the DisplayLink driver from scratch and update the list of available resolutions presented to Ubuntu.

This is a companion discussion topic for the original entry at
1 Like

OK I am going nutz and about to use this thing in the kitchen as a cutting board !!!

I have tried everything I can reference on the web and the only thing I get is a lot of other people saying they get no results either.

I am running an Odroid XU-4 and and older Lenovo laptop.
Both have fresh installs of ubuntu 18.04
Both have DKMS and the ‘displaylink-service’ driver installed

Neither will run the AOC 17", no matter which way I orient the USB cable,
powered off of a 5v 2A charger, from a powered USB hub or off the machine itself.

Both machines show the displaylink-driver service is running
However, xrandr shows nothing but my one monitor.

All I do get is:
When connected to the Odroid and the Odroid is unpowered
~(AOC monitor with it’s own power from power strip)
The monitor shows a logo of a screen and a USB indicating it needs to be plugged in.
If I just leave it like that the monitor eventually ‘screen saves’ by floating the logo around the screen.
AS SOON AS I POWER UP the computer the monitor goes black, dead, nada, nothing !

 I have had this thing for a year and a 1/2. I have revisited this issue a 1/2 dozen times and have about met my wits end !!!

PS> if I run ‘lsusb’ I can see:
“Bus 004 Device 003: ID 17e9:ff0c DisplayLink”

If that is peritent ?

Hi gilray,

I understand the frustration! From your above troubleshooting it sounds like this is driver issue since 1) Ubuntu is seeing the display on USB (given the output of ‘lsusb’) and 2) xrandr only shows your primary monitor.

Since the issue sounds like it’s still on the driver side, try following this guide exactly as written from DisplayLink.

Also, you’re not using secure boot are you?


I went through the steps to install. Plugging it in shows the connection with LSUSB:
Bus 001 Device 004: ID 17e9:4107 DisplayLink e1649Fwu
However, xrandr shows nothing. The monitor also doesn’t power up with or without the second usb plugged in.

Also, whether I start the computer with the AOC monitor plugged in, or plug in after startup, I get about a minute before everything locks up so completely I have to do a hard shutdown.

Tried on two computers with Ubuntu 20.04 – the older had a, Intel HD chip, the newer, a NVIDIA GeForce RTX 2060

Any clues why it doesn’t power on, show in the display list, or especially why it crashes my machine?

Very strange indeed. On one hand, your report of it not powering up suggests a hardware issue, but on the other, lsusb showing the device counters that theory.

Does the power come on at all? When I plug my AOC monitor in, even without the driver/setup, I at least get an AOC splash screen temporarily. Do you even get that?

Do you dual boot? Does it work okay with Windows? I also wonder if this might just be an issue with Ubuntu 20.04…